New PS4 games must also run on PlayStation 5 from July, Sony tells devs

New PS4 games must also run on PlayStation 5 from July, Sony tells devs

Sony has told PlayStation 4 game developers that any new titles submitted for certification must also be compatible with PlayStation 5, beginning 13th July.
This means all PS4 games received by Sony…
Read More

Вашият коментар

Вашият имейл адрес няма да бъде публикуван. Задължителните полета са отбелязани с *